Preprints (www.preprints.org) | NOT PEER-REVIEWED | Posted: 17 July 2018 d0i:10.20944/preprints201807.0302.v1

Technical Note

Deployment of OMNET 4+

Lesly Maygua-Marcillo!, Luis Urquiza-Aguiar!, Martha Paredes-Paredes!, Pablo
Barbecho Bautista?

1 Departamento de Electrénica, Telecomunicaciones y Redes de Informacién, Facultad de Eléctrica y

Electrénica, Escuela Politécnica Nacional (EPN), C. Ladrén de Guevara E11-253, Quito PO.Box
17-01-2759, Ecuador; lesly.maygua@epn.edu.ec, cecilia.paredes@epn.edu.ec.

Telematics Engineering Dept., Universitat Politécnica de Catalunya (UPC), Barcelona, Spain;
pablo.barbecho@upc.edu.

*  Correspondence: luis.urquiza@epn.edu.ec; Tel.:+593 2297-6300 ext.2311

Abstract: Nowadays, network simulators are frequently used to study services, applications and to
solve problems in complex scenarios of communications. For this reason, the objective of this article
is to introduce detailed information about installation of OMNET++ to new users. In this report,
we show how to install OMNET++4 simulator over a widely used distribution of Linux and how to
integrate "Inet", "Inetmanet" and "Veins" frameworks with the simulator. We take care to explain
this integration step-by-step. This tutorial includes: a virtual machine as additional material. Our
objective is make it easy for a beginner research community in OMNET++ and to maintain an open
environment of knowledge.
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1. Introduction

Communications are present in everything, and each day studies of this topic are realized. A
very useful tool to let studies of communications is a network simulator. With this tool we can build
realistic scenarios, predicts the behavior of wired and wireless networks [1] [2]. Analyze parameters and
protocols such as: QoS analysis [3], protocols analysis|[8], etc.

Nowadays, there are many network simulators such as: NS-2, NS-3 [4], OPNET, GNS3, NetSim,
among others [5] [7].

For this, reason we consider that is important the use of network simulators. And, in this occasion,
we want to contribute to the development and easy start of the use of the simulator Next, we detailed
important information for beginner research community in OMNET++.

2. Installation of OMNET++ simulator

With the purpose of reduce the size simulator it is necessary use as operative system Lubuntu, in
this case we use Lubuntu 16.04.

2.1. Prerequisite Package for Lubuntu

First, it is advisable to update the Lubuntu with its latest components through the following

instructions in a terminal:

sudo apt-get update

sudo apt-get upgrade
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Now, the core of OMNET++ requires various packages that are needed to make different tasks,
which are detailed below:

Minimal Requirements for Python
e gcc, gt+.
Requirements for Network Simulation Cradle
e flex, bison.
Xml-based version of the config store
e libxml2-dev.
Doxygen and related inline documentation
e doxygen, graphviz.
Qtenv 3D visualization support

e sudo add-apt-repository ppa:ubuntugis/ppa
e sudo apt-get update.

Osgearth development
e openscenegraph-plugin-osgearth libosgearth-dev
Recommended to install parallel simulation support
e openmpi-bin libopenmpi-dev
Optional Pcap

e libpcap-dev

2.2. Download and Install OMNET++

Once the prerequisites have been installed, download OMNeT++ from http://omnetpp.org [7].
Copy the archive to the directory where you want to install it.Open a terminal, and extract the archive
downloaded using the following command:

xvfz omnetpp-5.3-src.tgz

After that, a omnetpp-5.3 subdirectory with the OMNeT++ files will be created.

OMNeT++ needs its bin/ directory. To add bin/ to PATH permanently, it is advisable to set
environment variables. To set the environment variables, you should edit .bashrc in your home
directory. Use a text editor, for example: gedit ~/.bashrc

Add the following line at the end of the file. Save this change. Fig.1.
export PATH=$HOME/omnetpp-5.3/bin:$PATH

Now, is time to compile and build the default examples. You should be patient; the compilation
takes several minutes. For this, run the command below:

./configure
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# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
if [ -f /fusr/share/bash-completion/bash completion ]; then
. /usr/share/bash-completion/bash_completion
elif [ -f /etc/bash completion ]; then
. /etc/bash completion
fi
fi

|export PATH=$HOME/omnetpp-5. 3 /bin:$PATH |

Figure 1. Set the environment variables

checking for LibXML XML parser with CFLAGS=" -fPIC -Ifusr/include/libxml2" LIBS=

configure: Usi i X parsing
S -fPIC " LIBS="-lz"... yes
checking for Akaroa with CFLAG -fPIC -I/usr/local/akaroa/include” LIBS="-L/us
r/local/akaroa/1lib -lakaroa -1f1 . no
configure: WARNING: Optional package Akaroa not found
configure: creating ./config.status
config.status: creating Makefile.inc
config.status: creating src/qtenv/qtenv.pri

WARNING: The configuration script could not detect the following packages:
Akaroa (optional)

Scroll up to see the warning messages (use shift+PguUp), and search config.log

for more details. While you can use OMNeT++ in the current configuration,

be aware that some functionality may be unavailable or incomplete.

Your PATH contains /home/lesly/omnetpp-5.3/bin. Good!

OMNeT++ was configured with SWITH_QTENV = no. The Qt based graphical
runtime environment (Qtenv) will not be available.

Figure 2. Configuring OMNET++-.

If the build is successful, the message "Good!" will appear. In the case of some problem is shown
try the following command:

./configure WITH_TKENV=no WITH_QTENV=no

Now, when ./configure has finished, you can compile OMNeT++. Open a terminal and type:
make

A message of "type omnetpp to start the IDE" will appear, Fig.3.

= Compiling tictoc ====
Creating executable: out}gcc debug//tictoc_dbg
Compiling sockets =
Creating executable: out)‘gcc debugﬁ«:ocket: dbg
Compiling osg-intre
Creating executable: out;’gcc debug;;o:g intro_dbg
Compiling osg-earth ==

Creating executable: out/gcc- debug;;o:g earth_dbg
Compiling osg-indoor =
Creating executable: out/gcc-debug//osg-indoor_dbg
= Compiling osg-satellites =
Creating executable: out/gcc-debug//osg-satellites_dbg

Now you can type "omnetpp" to start the IDE

Figure 3. Make compiling

2.8. Verifying the installation

To verify the installation. First, you can typing the following command in the terminal to try the
OMNeT++ Simulation IDE Fig.3:

omnetpp
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If you need to recompile the simulator components with different parameters (e.g. different
optimization). You should change the top-level OMNeT++ directory, edit configure.user, typing:

./configure
make cleanall
make
2.4. Create a project

x Go to File - New — OMNeT++ Project

Fill the settings with the information below Fig.5:

* Choose a project name -> Next
* Initial Content -> Choose Empty/project

x Select project type -> Choose OMNeT++ Simulation
x Select Finish

New OMNeT++ Project
New OMNeT++ Project

Create a new OMNeT++ Project B

Project name:

& Use default location

& Support C++ Development

Figure 5. New OMNET++ project.
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2.4.1. Running the first script in OMNet++

You can execute the OMNeT++ projects by two ways. Through a terminal and with de simulator
IDE.
Using the IDE, the steps for running a program file are:

* Go to Project_name — e.g. File — Open file select the project and double click on to open it.

3. Adding INET Framework

INET is an open-source model library to simulate wired, wireless and mobile networks in
OMNeT++. Contains models for several Internet protocols.
To install this framework there are two ways: automatic and manual installation [11].

e Automatic Installation
Recent versions of the OMNeT++ can download and install INET for you. It is:
— Open the OMNeT++ IDE (omnetpp)
— A prompt will ask if you want to install INET.
— Keep the boxes checked and proceed.

If you skipped this step:
— Go to Help -> Install Simulation Models.Fig.6.

— A dialog will appear with the available simulation models, select INET and follow the prompts.

window |51,

, ¥ @ welcome
@ Help Contents
%’ search
IEW0  Dynamic Help
o Key Assist... Shife+Cerl+L
Tips and Tricks...
Cheat Sheets...

sy Report Bug or Enhancement...
| Install Simulation Models... I
Help on the OMNeT++ Sample Simulations...
% Check for Updates

3 @ Install New Software...
-0 di« ¥ Installation Details

—  mp Eclipse Marketplace...

& About OMNeT++ IDE

Figure 6. Help - Simulation models.

The IDE will download in both ways, unzip, and automatically build INET.
e Manual Installation
— Download the INET packages in https://inet.omnetpp.org/Download.html
— Unpack it into the directory of your preference using: xvfz inet-<version>.tgz

— Start the OMNeT++ IDE, and import the project: File -> Import -> Existing Projects to the
Workspace. A project named INET will be appear.

— Build with Project -> Build, or hit Ctr1+B.

You should be able to launch simulations.
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Figure 7. Inet framework installed

4. Adding INETMANET Framework

INETMANET is an extension of INET Framework but this adds features and protocols for mobile
ad-hoc networks [11]. The steps to install this framework are very similar to INET and these are show
bellow:

— Download Inetmanet package

Unpack into the directory of your preference by using: xvfz inetmanet-<version>.tgz

Start the OMNeT++ IDE, and import the project: File -> Import -> Existing Projects to the
Workspace.

— Finally, build with Project -> Build.

5. Adding VEINS Framework and SUMO

This framework of OMNeT++ includes a suite of models to make vehicular network simulations
as realistic as possible. The GUI and IDE of SUMO and OMNeT++ can be used for quickly setting up
and interactively simulations.

Below are shown the steps to the installation [12].

— First, check that the OMNET++ version previously installed is compatible with the selected
Veins release at https://veins.car2x.org/download/.

— Then, download Veins using https://veins.car2x.org/download/
— Unpack it in your selected directory.

— Import the project into your OMNeT++ IDE workspace. Click in File -> Import -> General:
Existing Projects to the Workspace and selecting the directory to unpacked the module framework
Fig.8.

— Build the newly imported project. Go to: Project -> Build All in OMNeT++ IDE.

With this steps you are ready to run your first IVC evaluations, but to ease debugging, the next
step will ensure that SUMO works good.


https://veins.car2x.org/download/
https://veins.car2x.org/download/
http://dx.doi.org/10.20944/preprints201807.0302.v1

Preprints (www.preprints.org) | NOT PEER-REVIEWED | Posted: 17 July 2018 d0i:10.20944/preprints201807.0302.v1

7 of 10

B Import -+ x
Select

S
Create new projects from an archive file or directory. H

Select an import source:

[type Filter text] al

- (& General
L& Archive File
I (= Existing Projects into Workspace I

] File System
[Cl Preferences

b CfCH

v (= Git

& Install

b = OMNeT++

+ = Run/Debug

v = Team

@ <Back || Mext> Cancel Finish

Figure 8. Installing Veins-Existing projects into workspace.
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I Generate NED Documentation...
Clean Up NED Files...

Figure 9. Building Veins.

5.1. SUMO installation

Before installing latest SUMO version, we strongly recommend to check OMNET++ and VEINS
compatibility at http://veins.car2x.org/download/ [6]. As prerequisites we have to install the following
packages [13][14]:

sudo apt-get install libgdal-dev libxerces-c-dev libproj-dev libfox-1.6-dev

Once the prerequisites have been installed, download SUMO from https://sourceforge.net/
projects/sumo/files/sumo/ [15]. Copy the archive .tar.gz to the directory where you want to install
it. SUMO also needs its bin/ directory. To add bin/ to PATH permanently, it is advisable to set
environment variable. To set the environment variable, you should edit .bashrc in your home directory.
Use a text editor, for example: gedit ~/.bashrc

Add the following line at the end of the file. Save this change.
export SUMO_HOME=$HOME/omnetpp-5.3/bin

Then, SUMO can be installed following the next steps in our simulator at SUMO folder [13][14].
You should be patient; the compilation takes several minutes. For this, run the commands below:

./configure

make
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make install

Next, we can verify the correct installation of this component through : sumo-gui. When typing
this command you should see a window similar to the shown in Fig.10

|| File Edit Settings Locate Simulation Windows Help

I || rime: [RRRRRRRRRRRR | Delay (ms): [ 0 <3 |

Open Simulation Configuration

Directory:l[j veins
3.

[ erlangen.sumo.cfg

File Name: I oK |
File Filter: I*‘sumo‘cfg.*‘sumocfg j Cancel |

Figure 10. Opening Sumo.

To run an example in sumo we can follow:

First, go to the directory where the example is located. Type the following command:

sumo-gui -c example.sumo.cfg

Immediately, the example will be shown on the screen Fig.11.

.sumo.cfg - SUMO 0.32.0 1
”;ﬂ File Edit Settings Locate Simulation Windows Help

” = @ @ |” I |” Time: _HJ Delay (ms): l—Uﬂﬂ
)

Figure 11. Running example in SUMO
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5.2. SUMO Map generation

We can use our own map for vehicular network simulations in Veins, using SUMO tools. In order to
simplify this procedure, first we have to export the desired map from https://www.openstreetmap.org
[16]. The file will has the extension .osm.

For the next step, we have to copy the generated file .osm into the sumo-0.32.0/bin directory.
Using SUMO tools, we convert the map from .osm to .net file. Type the following command:
netconvert -osm-files map.osm -o mymap.net.xml

To generate routes for vehicles with default configurations, execute the following python script:

python randomTrips.py -n mymap.net.xml -r mymap.rou.xml

In order to get a realistic simulation we can include buildings in the map with the following
command:

polyconvert -n mymap.net.xml -osm-files map.osm -o mymap.poly.xml

We have generated three files .net .rou and .poly all as xml files. We have to move these files to
the examples folder in veins directory and modify the files .Jaunch and .cfg with the names of the new
files "mymap" Fig.12.

x samples - Simulation - veins/examples/veins/erlangen.sumo.cfg - OMNeT++ IDE

File Edit Navigate Search Project Run Window Help

N A REE L O Q- -iF @8- -FH-oo-D-

5 |l Project Explorer 83 5% v=0O
[ |v Eveins [5) erlangen.sumo.cfg 2
b @l Includes <?xml version="1.0" encoding="is0-8859-1"?>
b (= doc . . .
! <configuration xmlns:xsi="http://www.w3.0rg/2001/XM
¥ (= examples
< & vei <input>
&veins <net-file value="mymap.net.xml"/>
[3) antenna.xml <route-files value="mymap.rou.xml"/>
[ config.xml <additional-files value="mymap.poly.xml"/>
. </input>
|Z debug
<time>
erlangen.launchd.xml <begin value="0"/>
rlangen.png <end value="1000"/>
<step-length value="0.1"/>
B erlangen.sumo.cfg </time>
=] memcheck
> <report>
[5 mymap.net.xml <no-step-log value="true"/>
[£) mymap.poly.xml </report>

[2) mymap.rou.xml <qui_only>
[») omnetpp.ini <start value="true"/>
</gui_only>

=/ README
[&3 RSUExampleScenario.ned </configuration>
2 run [
b (=images [2) erlangen.launchd.xml §2 "
<?xml version="1.0"?7>
> Esre <!-- debug config -->
b (= subprojects <launch>
<copy .net.xml" />
P Btests <copy .rou.xml" />
|Z] CHANGELOG <copy .poly.xml" />
o N <copy .sumo.cfg" type="config" />
8 configure </launch>
= COPYING

Figure 12. Map configuration for Veins

6. Additional Material

This tutorial includes a virtual machine with OMNET ++ simulator. This machine include the
inet, inetmanet, veins and sumo frameworks. Below, we show a table (Table 1) with the used
software versions in this tutorial with the objective to avoid installation problems.
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Table 1. My caption

Software Version
OMNeT++ 5.3

INET 3.4.0
VEINS 4.7
SUMO 0.32.0

Here concludes our tutorial. In the next section is added the additional material to perform test.
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